: TB의 SNS 이야기 :: tsProtector 업데이트 후 우회되던 앱이 안될 때 해결방법



최근 iOS 9.3.3 호환 업데이트 후 tsProtector 사용자들이 우회 하던 것들이 우회하지 못하는 불편함을 호소하고 있는데요.


해피포인트, OS 캐쉬백, 특정 쇼핑몰 앱, 모바일결제 ISP 등이 원래 우회를 했는데, 어느날 부터 위와 같은 팝업 메시지와 함께 실행이 되지 않을 때의 해결 방법입니다.


Case1. 업데이트 후 '차단우선' 설정이 → '허용우선' 으로 변경된 경우


'차단우선'으로 설정해뒀음에도 불구하고 업데이트 후 '허용우선'으로 변경되는 경우가 있다. 이럴 경우 extension settings에서 preference settings를 변경하면 된다.



Case2. 업데이트 후 지원 되던 것이 지원 되지 않는 경우 (iOS 9.x 완전탈옥 이하, 9.3.3 의 경우 트윅 호환 자체가 안된다.)


업데이트 후 지원 되던 것이 지원되지 않는다면, 업데이트 전 지원되던 버전으로 '다운그레이드' 하면 된다.


① Cyida를 실행한 후 tsProtector 패키지를 검색한다.


② 패키지 우측 상단 '변경'을 클릭한다.


③ '다운그레이드' → iOS 9.x 완전탈옥을 기준으로 1.1.3-65 버전으로 다운그레이드 한다.



'Flex 2' 의 경우 유저들이 공유하는 패치 파일을 다운로드 한 다음 적용하고 → 약간의 추가 수정이 필요합니다.


앱 마다 다르고, 사용 환경에 따라서 달라지기 때문에 본인이 직접 '공부' 하셔야 합니다. 그 많은 앱들과 사용 환경들을 일일히 다 설명하는 것은 물리적으로 '불가' 입니다.


또한 Flex 2의 문제점은 '오픈 패치' 기 때문에 누가 무엇을 어떻게 코딩한 지도 모르는 것을 '그냥 아무 생각 없이' 다운로드 받아서 적용하는 '자폭' 행위나 다름 없죠. 마치 인터넷 검색을 통해 .apk, .ipa, .deb ← 를 검색하여 설치하는 것과 같은 수준입니다.


(이러니까 국정원이 국민들을 만만히 보고 '멜웨어' 나 뿌려대지.)



tsProetctor 업데이트 소식에 관하여 전해드리자면, 어제 tsProtector 개발자에게 호환 업데이트에 관하여 요청을 해둔 상태인데요. 앱별 개별 플러그인을 설치토록 업데이트 예정이라고 합니다. 아마도, Flex 와 같은 형태가 될 것인데, 이런 형태는 원래 tsProtector의 전신인 kBankTweak 입니다.


 T.B의 SNS 이야기 블로그의 모든 글은 저작권법의 보호를 받습니다. 어떠한 상업적인 이용도 허가하지 않으며, 이용(불펌)허락을 하지 않습니다.

▲ 사전협의 없이 본 콘텐츠(기사, 이미지)의 무단 도용, 전재 및 복제, 배포를 금합니다. 이를 어길 시 민, 형사상 책임을 질 수 있습니다.

▲ 비영리 SNS(트위터, 페이스북 등), 온라인 커뮤니티, 카페 게시판에서는 자유롭게 공유 가능합니다.


T.B의 SNS이야기 소식은 T.B를 팔로윙(@ph_TB) 하시면 실시간으로 트위터를 통해서 제공 받을 수 있습니다.

Posted by T.B

댓글을 달아 주세요

  1. 2016.09.06 10:46  댓글주소  수정/삭제  댓글쓰기

    비밀댓글입니다

  2. BlogIcon Dr.NODISK 2016.09.09 00:27 신고  댓글주소  수정/삭제  댓글쓰기

    크 기대되네요! 우리카드 제발 좀 되길...