: TB의 SNS 이야기 :: 프로메테우스(Prometheus) 사용방법 인트로



iOS 다운그레이드가 가능한 유일한 방법인 프로메테우스(Prometheus)에 관한 전반적인 개념 소개다.


본격적으로 프로메테우스 사용방법을 따라하기 전, 모든 이들이 이 글을 읽어야 한다. 프로메테우스가 본인에게 적용되는지, 프로메테우스를 통한 다운그레이드에 필요한 요구 사항들을 충족시키는지를 확인해야 한다.


Yalu 탈옥이 배포된 후 많은 이들이 더 낮은 펌웨어로 부터 iOS 10.1.1 - 10.2까지 판올림을 통해 탈옥을 유지하는 방법을 묻고 있다. 결론 부터 말하자면 "없다." iOS 10.2 에 대한 SHSH2 blobs 백업이 없다면 불가다.


일부 사용자는 특정 요구 사항을 충족하는 한 서명 창이 닫힌 경우에도 iOS 10.2로 이동할 수 있습니다.


프로메테우스를 통한 다운그레이드를 시작하기 전 알아야 할 목록들을 꼭 읽어본 후 해당 작업이 본인에게 적용되는지를 확인하는 것이 우선이다. 누구나 프로메테우스 툴을 사용 할 수 있는 것은 아니다.


Things to consider(고려사항)


아래의 요구 사항들과 고려사항들을 통해 모든 것들을 만족하는지에 관하여 확인한다.


• iOS 10.2로 판올림 할 것인가? 더 낮은 펌웨어로 이미 탈옥 중이라면 왜 10.2로 탈옥해야 하는지의 이유에 관하여 고민할 필요가 있다. iOS 10.2 탈옥은 연간 $99의 비용이 들어가는 개발자 계정이 없는 한 7일 마다 PC를 이용하여 재인증을 해야 한다. 또한 완전탈옥이 아닌 준 탈옥으로 리부팅 시 마다 탈옥 앱을 실행해야 한다. 이런 번거로움이 없은 완전탈옥 중이라면 굳이 iOS 10.1.1 - 10.2의 탈옥을 서두를 필요가 없다.


 약간의 리스크가 있다. 많은 이들이 프로메테우스 툴을 성공적으로 사용했지만, 사용 과정이 상당히 복잡하며 복원 과정 중 문제가 발생 할 경우 iOS 10.2.1로 강제 업그레이드 해야 하는 경우가 발생할 수도 있다. 이는 iOS 10.2 탈옥이 영원히 불가능하다는 얘기가 될 수도 있으며, 모든 가이드를 완벽하게 따라하더라도 발생 할 수 있는 산발적인 버그, 충돌에 관한 리스크에 관한 책임은 모두 행위자 당사자에게 있다.


Requirements(요구사항)


아래의 조건들을 모두 만족시키지 못한다면 프로메테우스 툴을 사용할 수 없다.


 아이폰7 및 아이폰7플러스를 제외한 64 비트 iOS 기기


• 64비트 기기는 반드시 탈옥되어 tfp0가 활성되어 있어야 한다. 예외적으로 (어제 소개했던 내용)아이폰5 또는 아이패드에어1세대는 임시 충돌에 의거, iOS 10.3 베타1으로의 우회 다운그레이드 사례가 있다. 다른 모든 기기들은 반드시 탈옥이 되어 있는 상태야 하며, 탈옥되어 있지 않은 다른 기기들에 관한 질문은 받지 않는다.


• 임시 충돌이 있는 펌웨어(ex. iOS 10.3 b1, iOS 10.2, iOS 9.3.3)에 아이폰5 또는 아이패드에어1세대는 임시 충돌이 어떤 펌웨어에서 일어나는지에 관하여 확인해야 한다. 이는 매우 특정한 상황으로 iOS 10.2에 대한 SHSH2 blobs 또한 필요하다.


보다시피, 이는 매우 특정한 상황이다. 따라서 그 모든 것들이 무엇을 의미하는지 모른다면, '시도 하지 마라.'


• 다운그레이드를 하기 위한 펌웨어 (탈옥이 가능한 iOS 10.2)에 관하여 64비트 iOS 기기에 유효한 Blob를 백업해야 한다. 다운그레이드를 위해서는 blob이 .shsh2 파일이어야 한다. (blob이 TSS Saver를 사용하여 유효한가를 확인 할 수 있다.)


• Mac 또는 Linux 컴퓨터 또는 윈도우 컴퓨터에서 가상머신(Mac 또는 Linux)에 관한 엑세스가 필요하다. 이는 현재 윈도우를 지원하지 않기 때문이다. 윈도우 컴퓨터만 쓰는 경우 가상 머신 무료 평가판 또는 무료 리눅스인 우분투를 추천한다.


• 기기 모델에 대한 정확한 IPSW 파일이 필요하다. 이는 SEP 및 베이스밴드에 필요하다. 이러한 목적으로 iOS 10.2.1 및 iOS 10.2를 사용한다.


• Prometheus 도구, 즉 futurerestore 및 nonceEnabler. 임시 충돌 방법 유저(아이폰5, 아이패드에어1세대)들은 nonceEnabler가 필요하지 않지만 대부분의 유저들은 필요하다.


• Time and patience


How to use Prometheus to move to an unsigned firmware


위 요구 사항들을 만족하고, 파일들이 준비되면 가이드를 따라 다운그레이드를 진행 할 수 있다. 2가지 가이드가 있으며 혹자들은 반드시 따라야 하고, 거의 대부분의 유저들 또한 반드시 따라야 한다. (다른 방법이 없다.)


NonceEnabler 방법: 


현재 탈옥이 되어 있는 상태고, 프로메테우스의 nonceEnabler 방법으로 다른 펌웨어 버전으로 이동하기 위해서는 가이드의 1부 및 2부를 따라야 한다. 이것이 가장 권장되는 방법이며 대부분의 유저들이 프로메테우스를 사용한다.


Nonce collision(임시 충돌) 방법:


만약, 현재 탈옥되어 있지 않은 순정 상태에서, 프로메테우스를 통해서 다른 펌웨어 버전으로 이동하기 위해서는 1번을 건너뛰고, 2번 부분만 수행한다. 매우 제한적인 경우에만 다운그레이드가 가능하다. '시간을 낭비하기 전에' 요구사항을 주의 깊게 확인하라.


가이드(Guide)


• Prometheus Guide Part 1: How to set a nonce with nonceEnabler


• Prometheus Guide Part 2: How to use futurerestore to restore to unsigned firmwares


Good luck, 당신의 복원이 성공적으로 이루어지길 기원한다! 복원을 시도하기 전 이 글을 주의 깊게 읽지 않은 한, 부적절한 질문은 하지 않는다.


번역: idownloadblog


 비영리로 운영중인 'T.B의 SNS 이야기' 블로그의 모든 글은 저작권법의 보호를 받습니다. 어떠한 상업적인 이용도 허가하지 않으며, 이용(불펌)허락을 하지 않습니다.

▲ 사전협의 없이 본 콘텐츠(기사, 이미지)의 무단 도용, 전재 및 복제, 배포를 금합니다. 이를 어길 시 민, 형사상 책임을 질 수 있습니다.

▲ 비영리 SNS(트위터, 페이스북 등), 온라인 커뮤니티, 카페 게시판에서는 자유롭게 공유 가능합니다.


T.B의 SNS이야기(http://ryueyes11.tistory.com/)소식은 T.B를 팔로윙(@ph_TB) 하시면 실시간으로 트위터를 통해서 제공 받을 수 있습니다


Posted by T.B

댓글을 달아 주세요

  1. 2017.02.28 04:26  댓글주소  수정/삭제  댓글쓰기

    비밀댓글입니다